netflow配置

/**********************************************DUT1(7812)**********************************************/


ip vpn-instance nf1
route-distinguisher 200:1
exit

interface vlan 4009
ip binding vpn-instance nf1
ip address 10.18.16.133/24
exit

interface gigaethernet 11/0/2
port hybrid vlan 4009 untagged
port hybrid pvid 4009
no port hybrid vlan 1
no shut
exit

netflow exporter exporter1
destination ip 10.18.16.188 vpn-instance nf1
transport udp-port 9996
exit


netflow record record1
match ipv4 src-addr
match ipv4 dst-addr
collect in-bytes
collect in-pkts
collect out-bytes
collect out-pkts
exit
netflow record record2
match ipv6 src-addr
match ipv6 dst-addr
collect in-bytes
collect in-pkts
collect out-bytes
collect out-pkts
exit
netflow record record3
match in-src-mac
match in-dst-mac
collect in-bytes
collect in-pkts
collect out-bytes
collect out-pkts
collect in-src-mac
collect in-dst-mac
exit
netflow monitor monitor10
record record1
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor20
record record2
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor30
record record3
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor11
record record1
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor21
record record2
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor31
record record3
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor12
record record1
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor22
record record2
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor32
record record3
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor13
record record1
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor23
record record2
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor33
record record3
exporter exporter1
cache size 10240
cache type permanent
exit


!***************enable netflow****************
interface xgigaethernet 9/0/1
ip flow monitor monitor10 in
ip flow monitor monitor10 out
ipv6 flow monitor monitor20 in
ipv6 flow monitor monitor20 out
l2 flow monitor monitor30 in
l2 flow monitor monitor30 out
exit

interface xgigaethernet 9/0/2
ip flow monitor monitor11 in
ip flow monitor monitor11 out
ipv6 flow monitor monitor21 in
ipv6 flow monitor monitor21 out
l2 flow monitor monitor31 in
l2 flow monitor monitor31 out
e

xit
interface xgigaethernet 9/0/3
ip flow monitor monitor12 in
ip flow monitor monitor12 out
ipv6 flow monitor monitor22 in
ipv6 flow monitor monitor22 out
l2 flow monitor monitor32 in
l2 flow monitor monitor32 out
exit
interface xgigaethernet 9/0/4
ip flow monitor monitor13 in
ip flow monitor monitor13 out
ipv6 flow monitor monitor23 in
ipv6 flow monitor monitor23 out
l2 flow monitor monitor33 in
l2 flow monitor monitor33 out
exit









**************** disable netflow ******************
interface xgigaethernet 9/0/1
no ip flow monitor monitor10 in
no ip flow monitor monitor10 out
no ipv6 flow monitor monitor20 in
no ipv6 flow monitor monitor20 out
no l2 flow monitor monitor30 in
no l2 flow monitor monitor30 out

interface xgigaethernet 9/0/2
no ip flow monitor monitor11 in
no ip flow monitor monitor11 out
no ipv6 flow monitor monitor21 in
no ipv6 flow monitor monitor21 out
no l2 flow monitor monitor31 in
no l2 flow monitor monitor31 out

interface xgigaethernet 9/0/3
no ip flow monitor monitor12 in
no ip flow monitor monitor12 out
no ipv6 flow monitor monitor22 in
no ipv6 flow monitor monitor22 out
no l2 flow monitor monitor32 in
no l2 flow monitor monitor32 out

interface xgigaethernet 9/0/4
no ip flow monitor monitor13 in
no ip flow monitor monitor13 out
no ipv6 flow monitor monitor23 in
no ipv6 flow monitor monitor23 out
no l2 flow monitor monitor33 in
no l2 flow monitor monitor33 out
















/*********************************************DUT2(7808)*********************************************/

ip vpn-instance nf1
route-distinguisher 200:1
exit

interface vlan 4009
ip binding vpn-instance nf1
ip address 10.18.16.133/24
exit

interface gigaethernet 7/0/2
port hybrid vlan 4009 untagged
port hybrid pvid 4009
no port hybrid vlan 1
no shut
exit

netflow exporter exporter1
destination ip 10.18.16.188 vpn-instance nf1
transport udp-port 9996
exit


netflow record record1
match ipv4 src-addr
match ipv4 dst-addr
collect in-bytes
collect in-pkts
collect out-bytes
collect out-pkts
exit
netflow record record2
match ipv6 src-addr
match ipv6 dst-addr
collect in-bytes
collect in-pkts
collect out-bytes
collect out-pkts
exit
netflow record record3
match in-src-mac
match in-dst-mac
collect in-bytes
collect in-pkts
collect out-bytes
collect out-pkts
collect in-src-mac
collect in-dst-mac
exit
netflow monitor monitor10
record record1
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor20
record record2
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor30
record record3
exporter exporter1
cache size 10240
cache type per

manent
exit
netflow monitor monitor11
record record1
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor21
record record2
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor31
record record3
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor12
record record1
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor22
record record2
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor32
record record3
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor13
record record1
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor23
record record2
exporter exporter1
cache size 10240
cache type permanent
exit
netflow monitor monitor33
record record3
exporter exporter1
cache size 10240
cache type permanent
exit


!***************enable netflow****************
interface xgigaethernet 4/0/1
ip flow monitor monitor10 in
ip flow monitor monitor10 out
ipv6 flow monitor monitor20 in
ipv6 flow monitor monitor20 out
l2 flow monitor monitor30 in
l2 flow monitor monitor30 out
exit

interface xgigaethernet 4/0/2
ip flow monitor monitor11 in
ip flow monitor monitor11 out
ipv6 flow monitor monitor21 in
ipv6 flow monitor monitor21 out
l2 flow monitor monitor31 in
l2 flow monitor monitor31 out
exit
interface xgigaethernet 4/0/3
ip flow monitor monitor12 in
ip flow monitor monitor12 out
ipv6 flow monitor monitor22 in
ipv6 flow monitor monitor22 out
l2 flow monitor monitor32 in
l2 flow monitor monitor32 out
exit
interface xgigaethernet 4/0/4
ip flow monitor monitor13 in
ip flow monitor monitor13 out
ipv6 flow monitor monitor23 in
ipv6 flow monitor monitor23 out
l2 flow monitor monitor33 in
l2 flow monitor monitor33 out
exit









**************** disable netflow ******************
interface xgigaethernet 4/0/1
no ip flow monitor monitor10 in
no ip flow monitor monitor10 out
no ipv6 flow monitor monitor20 in
no ipv6 flow monitor monitor20 out
no l2 flow monitor monitor30 in
no l2 flow monitor monitor30 out

interface xgigaethernet 4/0/2
no ip flow monitor monitor11 in
no ip flow monitor monitor11 out
no ipv6 flow monitor monitor21 in
no ipv6 flow monitor monitor21 out
no l2 flow monitor monitor31 in
no l2 flow monitor monitor31 out

interface xgigaethernet 4/0/3
no ip flow monitor monitor12 in
no ip flow monitor monitor12 out
no ipv6 flow monitor monitor22 in
no ipv6 flow monitor monitor22 out
no l2 flow monitor monitor32 in
no l2 flow monitor monitor32

out

interface xgigaethernet 4/0/4
no ip flow monitor monitor13 in
no ip flow monitor monitor13 out
no ipv6 flow monitor monitor23 in
no ipv6 flow monitor monitor23 out
no l2 flow monitor monitor33 in
no l2 flow monitor monitor33 out







相关文档
最新文档